TrustVault Incident Identified
Incident Report for Bitpanda Custody Ltd
Resolved
The recent incident regarding TrustVault has been resolved and normal service resumed.
Posted Oct 22, 2019 - 20:51 UTC
Identified
We have identified an incident concerning Ethereum transaction history in TrustVault and are working to apply a fix. Balance queries and transactions are still functioning as normal.
Posted Oct 22, 2019 - 13:59 UTC
This incident affected: TrustVault.