Trustology Website Incident Identified
Incident Report for Trustology Ltd
Resolved
The recent incident regarding Trustology website has been resolved and normal service resumed.
Posted May 04, 2019 - 09:35 UTC
Update
We are continuing to work on a fix for this issue.
Posted May 04, 2019 - 09:34 UTC
Identified
We have identified the cause of the recent reported incident concerning the Trustology Website and are working to apply a fix. The service may be unavailable while we proceed.
Posted May 04, 2019 - 09:29 UTC
This incident affected: Website and TrustVault.