Ethereum transaction history stalled
Incident Report for Bitpanda Custody Ltd
Resolved
Our index has reached the head of the chain and is operating normally.
Posted Mar 15, 2020 - 08:14 UTC
Monitoring
The system is now processing block again. We expect to have reached the head of the chain by 8:30 GMT
Posted Mar 15, 2020 - 07:47 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 15, 2020 - 07:44 UTC
This incident affected: TrustVault.