TrustVault iOS App incorrect fiat conversion amounts for ERC-20 transfers
Incident Report for Bitpanda Custody Ltd
Resolved
This incident has been resolved.
Posted Feb 24, 2022 - 16:16 UTC
Identified
For ERC-20 transfers initiated by MetaMask the TrustVault iOS app shows the incorrect fiat price.
For TrustVault supported assets it will show the current ETH price (~2,800 GBP), for other tokens it will show a price of 0 GBP.
If your app is set to a different currency the values will be shown in that currency.

We are currently looking into a fix for this issue.
You can be assured that your transfers will be correct, this is simply a display issue.

Please reach out to us if you have any concerns.
Posted Dec 30, 2021 - 16:56 UTC
This incident affected: TrustVault.