Trustology Metamask extension
Incident Report for Bitpanda Custody Ltd
Resolved
We have not had any reported issues with the new extension.

If you experience any further issues after installing the update please contact the Trustology Support team.
Posted Jan 15, 2021 - 16:10 UTC
Monitoring
The new version of the extension is now approved and available in the chrome store (version 1.3.2) Please install the update to continue to be able to use it.
If you experience any further issues after installing the update please contact the Trustology Support team.
Posted Jan 15, 2021 - 10:04 UTC
Identified
We have identified an issue with the Trustology MetaMask extension. A new version is currently being released to the Google Play store but may take a few days to become available.
Please contact the Trustology Support team if you are impacted this.
Posted Jan 14, 2021 - 12:20 UTC
This incident affected: TrustVault MetaMask Extension.